Started 3 months ago19th May, 2026Lasted about 1 hour19th May, 202613:3914:40UTC
Affected
Telephony
Major outage from 1:39 PM to 2:40 PM
Updates
Resolved
UTC
Resolved
UTC
The incident affecting telephony has now been resolved.
We apologize for any inconvenience this may have caused.
Regards,
Resurs Bank IT
Investigating
UTC
Investigating
UTC
We are currently experiencing issues with our telephony services. We are working to resolve the incident as quickly as possible. We apologize for any inconvenience this may cause.